Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. uppy
  4. ›
  5. CVE-2020-8135

CVE-2020-8135: Server-Side Request Forgery (SSRF)

March 20, 2020 (updated March 24, 2020)

The uppy npm package is vulnerable to a Server-Side Request Forgery (SSRF) vulnerability, which allows an attacker to scan local or external networks or otherwise interact with internal systems.

References

  • hackerone.com/reports/786956
  • nvd.nist.gov/vuln/detail/CVE-2020-8135

Code Behaviors & Features

Detect and mitigate CVE-2020-8135 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.9.3

Fixed versions

  • 1.9.3

Solution

Upgrade to version 1.9.3 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-918: Server-Side Request Forgery (SSRF)

Source file

npm/uppy/CVE-2020-8135.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:37 +0000.