Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. undici
  4. ›
  5. CVE-2026-109841

CVE-2026-109841: undici vulnerable to Subresource Integrity bypass via non-lowercase algorithm tokens

October 23, 2026

undici’s fetch() verifies Subresource Integrity (SRI) metadata by looking up the algorithm token in a lowercase-only set, but the SRI specification defines a valid token by its ASCII-lowercase form. A correct but non-lowercase token such as SHA256-... or Sha256-... is therefore treated as unknown and skipped. When no recognized algorithm remains, undici treats the integrity list as empty and accepts the response, so a server that returns a body different from the pinned digest passes the check.

An application that pins a response with a valid uppercase or mixed-case SRI token receives attacker-controlled bytes with no integrity error. The attacker needs only to control the response body, not the application’s integrity metadata. The issue affects response integrity only. The regression was introduced in undici 7.15.0; releases 7.14.0 and earlier lowercase the token and are not affected.

References

  • cna.openjsf.org/security-advisories.html
  • github.com/advisories/GHSA-f72v-6w45-q472
  • github.com/nodejs/undici/commit/18bc8a1e09d15bc45815154a289dcf6fd5254d00
  • github.com/nodejs/undici/commit/4f7ef6806e532ab9e29ccd6229b1b9d241e1b1f0
  • github.com/nodejs/undici/releases/tag/v7.30.1
  • github.com/nodejs/undici/releases/tag/v8.12.2
  • github.com/nodejs/undici/security/advisories/GHSA-f72v-6w45-q472
  • nvd.nist.gov/vuln/detail/CVE-2026-109841

Code Behaviors & Features

Detect and mitigate CVE-2026-109841 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.15.0 before 7.30.1, all versions starting from 8.0.0 before 8.12.2

Fixed versions

  • 7.30.1
  • 8.12.2

Solution

Upgrade to versions 7.30.1, 8.12.2 or above.

Impact 5.9 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-178: Improper Handling of Case Sensitivity

Source file

npm/undici/CVE-2026-109841.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:16 +0000.