Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ua-parser-js
  4. ›
  5. CVE-2021-27292

CVE-2021-27292: Uncontrolled Resource Consumption

March 17, 2021 (updated March 23, 2021)

ua-parser-js uses a regular expression which is vulnerable to denial of service. If an attacker sends a malicious User-Agent header, ua-parser-js will get stuck processing it for an extended period of time.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-27292

Code Behaviors & Features

Detect and mitigate CVE-2021-27292 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 0.7.14 before 0.7.24

Fixed versions

  • 0.7.24

Solution

Upgrade to version 0.7.24 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

npm/ua-parser-js/CVE-2021-27292.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.