Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. trix
  4. ›
  5. CVE-2025-21610

CVE-2025-21610: Trix allows Cross-site Scripting via `javascript:` url in a link

January 3, 2025

The Trix editor, versions prior to 2.1.11, is vulnerable to XSS when pasting malicious code in the link field.

References

  • gist.github.com/th4s1s/3921fd9c3e324ad9a3e0d846166e3eb8
  • github.com/advisories/GHSA-j386-3444-qgwg
  • github.com/basecamp/trix
  • github.com/basecamp/trix/commit/180c8d337f18e1569cea6ef29b4d03ffff5b5faa
  • github.com/basecamp/trix/commit/c4f0d6f80654603932af6685694f694e96593b93
  • github.com/basecamp/trix/security/advisories/GHSA-j386-3444-qgwg
  • nvd.nist.gov/vuln/detail/CVE-2025-21610

Code Behaviors & Features

Detect and mitigate CVE-2025-21610 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.1.12

Fixed versions

  • 2.1.12

Solution

Upgrade to version 2.1.12 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/trix/CVE-2025-21610.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:30 +0000.