Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. tarteaucitronjs
  4. ›
  5. CVE-2025-1467

CVE-2025-1467: tarteaucitron Cross-site Scripting (XSS)

February 23, 2025 (updated February 24, 2025)

Versions of the package tarteaucitronjs before 1.17.0 are vulnerable to Cross-site Scripting (XSS) via the getElemWidth() and getElemHeight(). This is related to SNYK-JS-TARTEAUCITRONJS-8366541

References

  • gist.github.com/Rudloff/d48f525215bd5426cbb076116c4422dd
  • github.com/AmauriC/tarteaucitron.js
  • github.com/AmauriC/tarteaucitron.js/commit/12490579001d5caa187adcaecb01da570a12076b
  • github.com/AmauriC/tarteaucitron.js/issues/1184
  • github.com/advisories/GHSA-8wp9-x25p-8794
  • nvd.nist.gov/vuln/detail/CVE-2025-1467
  • security.snyk.io/vuln/SNYK-JS-TARTEAUCITRONJS-8731160

Code Behaviors & Features

Detect and mitigate CVE-2025-1467 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.17.0

Fixed versions

  • 1.17.0

Solution

Upgrade to version 1.17.0 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/tarteaucitronjs/CVE-2025-1467.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:50 +0000.