Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. tar-fs
  4. ›
  5. CVE-2018-20835

CVE-2018-20835: Improper Input Validation

April 30, 2019 (updated May 3, 2019)

A vulnerability was found in tar-fs. An Arbitrary File Overwrite issue exists when extracting a tarball containing a hardlink to a file that already exists on the system, in conjunction with a later plain file with the same name as the hardlink. This plain file content replaces the existing file content.

References

  • nvd.nist.gov/vuln/detail/CVE-2018-20835

Code Behaviors & Features

Detect and mitigate CVE-2018-20835 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.16.2

Fixed versions

  • 1.16.2

Solution

Upgrade to version 1.16.2 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/tar-fs/CVE-2018-20835.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.