Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. swagger-ui
  4. ›
  5. CVE-2021-46708

CVE-2021-46708: Improper Restriction of Rendered UI Layers or Frames

March 11, 2022 (updated June 1, 2022)

The swagger-ui-dist package before 4.1.3 for Node.js could allow a remote attacker to hijack the clicking action of the victim. By persuading a victim to visit a malicious Web site, a remote attacker could exploit this vulnerability to hijack the victim’s click actions and possibly launch further attacks against the victim.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-46708
  • security.snyk.io/vuln/SNYK-JS-SWAGGERUIDIST-2314884
  • www.npmjs.com/package/swagger-ui-dist/v/4.1.3

Code Behaviors & Features

Detect and mitigate CVE-2021-46708 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.3

Fixed versions

  • 4.1.3

Solution

Upgrade to version 4.1.3 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-1021: Improper Restriction of Rendered UI Layers or Frames

Source file

npm/swagger-ui/CVE-2021-46708.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:25 +0000.