Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. swagger-ui
  4. ›
  5. CVE-2018-25031

CVE-2018-25031: Spoofing attack in swagger-ui

March 12, 2022 (updated September 2, 2025)

Swagger UI before 4.1.3 could allow a remote attacker to conduct spoofing attacks. By persuading a victim to open a crafted URL, an attacker could exploit this vulnerability to display remote OpenAPI definitions.

References

  • github.com/advisories/GHSA-cr3q-pqgq-m8c2
  • github.com/swagger-api/swagger-ui
  • github.com/swagger-api/swagger-ui/issues/4872
  • github.com/swagger-api/swagger-ui/pull/7697
  • github.com/swagger-api/swagger-ui/releases/tag/v4.1.3
  • nvd.nist.gov/vuln/detail/CVE-2018-25031
  • security.netapp.com/advisory/ntap-20220407-0004
  • security.snyk.io/vuln/SNYK-JS-SWAGGERUI-2314885

Code Behaviors & Features

Detect and mitigate CVE-2018-25031 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 4.1.3

Fixed versions

  • 4.1.3

Solution

Upgrade to version 4.1.3 or above.

Impact 4.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation
  • CWE-918: Server-Side Request Forgery (SSRF)
  • CWE-922: Insecure Storage of Sensitive Information

Source file

npm/swagger-ui/CVE-2018-25031.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:52 +0000.