Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. svelte
  4. ›
  5. GHSA-gw32-9rmw-qwww

GHSA-gw32-9rmw-qwww: svelte is vulnerable to XSS with textarea bind:value

January 16, 2026

A server-side rendered <textarea> with two-way bound value does not have its value correctly escaped in the rendered HTML.

References

  • github.com/advisories/GHSA-gw32-9rmw-qwww
  • github.com/sveltejs/svelte
  • github.com/sveltejs/svelte/commit/a31dec5eb30978cff7ff4d77f4bf316841f711bc
  • github.com/sveltejs/svelte/security/advisories/GHSA-gw32-9rmw-qwww

Code Behaviors & Features

Detect and mitigate GHSA-gw32-9rmw-qwww with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 3.0.0 before 3.59.2

Fixed versions

  • 3.59.2

Solution

Upgrade to version 3.59.2 or above.

Impact 9.3 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/svelte/GHSA-gw32-9rmw-qwww.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:05 +0000.