Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. svelte
  4. ›
  5. CVE-2026-27121

CVE-2026-27121: Svelte affected by cross-site scripting via spread attributes in Svelte SSR

February 19, 2026 (updated February 23, 2026)

Versions of svelte prior to 5.51.5 are vulnerable to cross-site scripting (XSS) during server-side rendering. When using spread syntax to render attributes from untrusted data, event handler properties are included in the rendered HTML output. If an application spreads user-controlled or external data as element attributes, an attacker can inject malicious event handlers that execute in victims’ browsers.

References

  • github.com/advisories/GHSA-f7gr-6p89-r883
  • github.com/sveltejs/svelte
  • github.com/sveltejs/svelte/security/advisories/GHSA-f7gr-6p89-r883
  • nvd.nist.gov/vuln/detail/CVE-2026-27121

Code Behaviors & Features

Detect and mitigate CVE-2026-27121 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.51.5

Fixed versions

  • 5.51.5

Solution

Upgrade to version 5.51.5 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/svelte/CVE-2026-27121.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.