Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. svelte
  4. ›
  5. CVE-2025-15265

CVE-2025-15265: svelte vulnerable to Cross-site Scripting

January 15, 2026

An XSS vulnerability exists in Svelte 5.46.0-2 resulting from improper escaping of hydratable keys. If these keys incorporate untrusted user input, arbitrary JavaScript can be injected into server-rendered HTML.

References

  • github.com/advisories/GHSA-6738-r8g5-qwp3
  • github.com/sveltejs/svelte
  • github.com/sveltejs/svelte/commit/ef81048e238844b729942441541d6dcfe6c8ccca
  • github.com/sveltejs/svelte/releases/tag/svelte%405.46.4
  • github.com/sveltejs/svelte/security/advisories/GHSA-6738-r8g5-qwp3
  • nvd.nist.gov/vuln/detail/CVE-2025-15265

Code Behaviors & Features

Detect and mitigate CVE-2025-15265 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.46.0 before 5.46.4

Fixed versions

  • 5.46.4

Solution

Upgrade to version 5.46.4 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/svelte/CVE-2025-15265.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:25 +0000.