Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. strapi
  4. ›
  5. CVE-2020-13961

CVE-2020-13961: Improper Input Validation

June 19, 2020 (updated June 24, 2020)

Strapi could allow a remote authenticated attacker to bypass security restrictions because templates are stored in a global variable without any sanitation. By sending a specially crafted request, an attacker could exploit this vulnerability to update the email template for both password reset and account confirmation emails.

References

  • exchange.xforce.ibmcloud.com/vulnerabilities/183045
  • nvd.nist.gov/vuln/detail/CVE-2020-13961

Code Behaviors & Features

Detect and mitigate CVE-2020-13961 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.0.2

Fixed versions

  • 3.0.2

Solution

Upgrade to version 3.0.2 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/strapi/CVE-2020-13961.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:04 +0000.