Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. strapi
  4. ›
  5. CVE-2019-19609

CVE-2019-19609: Command Injection in strapi

September 4, 2020 (updated December 29, 2025)

Versions of strapi before 3.0.0-beta.17.8 are vulnerable to Command Injection. The package fails to sanitize plugin names in the /admin/plugins/install/ route. This may allow an authenticated attacker with admin privileges to run arbitrary commands in the server.

References

  • bittherapy.net/post/strapi-framework-remote-code-execution
  • github.com/advisories/GHSA-9p2w-rmx4-9mw7
  • github.com/strapi/strapi
  • github.com/strapi/strapi/pull/4636
  • nvd.nist.gov/vuln/detail/CVE-2019-19609
  • www.npmjs.com/advisories/1424

Code Behaviors & Features

Detect and mitigate CVE-2019-19609 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.0.0-beta.17.8

Fixed versions

  • 3.0.0-beta.17.8

Solution

Upgrade to version 3.0.0-beta.17.8 or above.

Impact 7.2 HIGH

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')

Source file

npm/strapi/CVE-2019-19609.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.