Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. store2
  4. ›
  5. CVE-2024-57556

CVE-2024-57556: Cross Site Scripting vulnerability in store2

January 24, 2025

Cross Site Scripting vulnerability in nbubna store v.2.14.2 and before allows a remote attacker to execute arbitrary code via the store.deep.js component

References

  • github.com/advisories/GHSA-w5hq-hm5m-4548
  • github.com/nbubna/store
  • github.com/nbubna/store/issues/127
  • github.com/nbubna/store/pull/128
  • nvd.nist.gov/vuln/detail/CVE-2024-57556

Code Behaviors & Features

Detect and mitigate CVE-2024-57556 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2.14.4

Fixed versions

  • 2.14.4

Solution

Upgrade to version 2.14.4 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/store2/CVE-2024-57556.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:14 +0000.