Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. simple-git
  4. ›
  5. CVE-2022-24066

CVE-2022-24066: Improper Neutralization of Special Elements used in a Command ('Command Injection')

April 1, 2022 (updated August 8, 2023)

The package simple-git before 3.5.0 is vulnerable to Command Injection due to an incomplete fix of CVE-2022-24433 which only patches against the git fetch attack vector. A similar use of the –upload-pack feature of git is also supported for git clone, which the prior fix didn’t cover.

References

  • gist.github.com/lirantal/a930d902294b833514e821102316426b
  • github.com/advisories/GHSA-28xr-mwxg-3qc8
  • github.com/steveukx/git-js/commit/2040de601c894363050fef9f28af367b169a56c5
  • nvd.nist.gov/vuln/detail/CVE-2022-24066
  • snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-2434820
  • snyk.io/vuln/SNYK-JS-SIMPLEGIT-2434306

Code Behaviors & Features

Detect and mitigate CVE-2022-24066 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.5.0

Fixed versions

  • 3.5.0

Solution

Upgrade to version 3.5.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-88: Improper Neutralization of Argument Delimiters in a Command ('Argument Injection')

Source file

npm/simple-git/CVE-2022-24066.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:44 +0000.