Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. serve
  4. ›
  5. CVE-2019-5417

CVE-2019-5417: Path Traversal

March 21, 2019 (updated March 25, 2019)

A path traversal vulnerability in serve allows attackers to read content of arbitrary files on the remote server.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-5417

Code Behaviors & Features

Detect and mitigate CVE-2019-5417 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 7.0.1 before 7.3.1

Fixed versions

  • 8.0.0

Solution

Upgrade to version 8.0.0 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

npm/serve/CVE-2019-5417.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:51 +0000.