Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. serve-static
  4. ›
  5. CVE-2024-43800

CVE-2024-43800: serve-static vulnerable to template injection that can lead to XSS

September 10, 2024 (updated November 18, 2024)

passing untrusted user input - even after sanitizing it - to redirect() may execute untrusted code

References

  • github.com/advisories/GHSA-cm22-4g7w-348p
  • github.com/expressjs/serve-static
  • github.com/expressjs/serve-static/commit/0c11fad159898cdc69fd9ab63269b72468ecaf6b
  • github.com/expressjs/serve-static/commit/ce730896fddce1588111d9ef6fdf20896de5c6fa
  • github.com/expressjs/serve-static/security/advisories/GHSA-cm22-4g7w-348p
  • nvd.nist.gov/vuln/detail/CVE-2024-43800

Code Behaviors & Features

Detect and mitigate CVE-2024-43800 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.16.0, all versions starting from 2.0.0 before 2.1.0

Fixed versions

  • 1.16.0
  • 2.1.0

Solution

Upgrade to versions 1.16.0, 2.1.0 or above.

Impact 4.7 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/serve-static/CVE-2024-43800.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:43 +0000.