Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. serve-index
  4. ›
  5. CVE-2015-8856

CVE-2015-8856: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

October 24, 2017 (updated September 20, 2021)

Cross-site scripting (XSS) vulnerability in the serve-index package before 1.6.3 for Node.js allows remote attackers to inject arbitrary web script or HTML via a crafted file or directory name.

References

  • www.openwall.com/lists/oss-security/2016/04/20/11
  • www.securityfocus.com/bid/96392
  • github.com/advisories/GHSA-v633-x5vv-hqwc
  • github.com/expressjs/serve-index/issues/28
  • nodesecurity.io/advisories/34
  • nvd.nist.gov/vuln/detail/CVE-2015-8856
  • www.npmjs.com/advisories/34

Code Behaviors & Features

Detect and mitigate CVE-2015-8856 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.6.3

Fixed versions

  • 1.6.3

Solution

Upgrade to version 1.6.3 or above.

Impact 6.1 MEDIUM

CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/serve-index/CVE-2015-8856.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:07 +0000.