Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. sequelize
  4. ›
  5. CVE-2019-11069

CVE-2019-11069: Improper Input Validation

April 10, 2019 (updated April 22, 2019)

Sequelize does not properly ensure that standard conforming strings are used.

References

  • nvd.nist.gov/vuln/detail/CVE-2019-11069

Code Behaviors & Features

Detect and mitigate CVE-2019-11069 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 5.0.0 before 5.3.0

Fixed versions

  • 5.3.0

Solution

Upgrade to version 5.3.0 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/sequelize/CVE-2019-11069.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:41 +0000.