Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. riot-compiler
  4. ›
  5. CVE-2016-10527

CVE-2016-10527: Improper Input Validation

May 31, 2018 (updated October 9, 2019)

The riot-compiler version has an issue in a regex (Catastrophic Backtracking) that make it unusable under certain conditions.

References

  • nvd.nist.gov/vuln/detail/CVE-2016-10527

Code Behaviors & Features

Detect and mitigate CVE-2016-10527 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

Version 2.3.21

Fixed versions

  • 2.3.22

Solution

Upgrade to version 2.3.22 or above.

Impact 7.5 HIGH

CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-399

Source file

npm/riot-compiler/CVE-2016-10527.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:45 +0000.