Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. raneto
  4. ›
  5. CVE-2022-35143

CVE-2022-35143: Weak Password Requirements

August 4, 2022 (updated August 10, 2022)

Renato v0.17.0 employs weak password complexity requirements, allowing attackers to crack user passwords via brute-force attacks.

References

  • raneto.com/
  • cwe.mitre.org/data/definitions/521.html
  • gainsec.com/2022/08/04/cve-2022-35142-cve-2022-35143-cve-2022-35144/
  • github.com/gilbitron/Raneto/releases
  • nvd.nist.gov/vuln/detail/CVE-2022-35143

Code Behaviors & Features

Detect and mitigate CVE-2022-35143 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.17.1

Fixed versions

  • 0.17.1

Solution

Upgrade to version 0.17.1 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-521: Weak Password Requirements

Source file

npm/raneto/CVE-2022-35143.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:07 +0000.