Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. qwc2
  4. ›
  5. CVE-2025-11183

CVE-2025-11183: QGIS QWC2 Cross-Site Scripting vulnerability

October 13, 2025 (updated November 5, 2026)

Cross-Site Scripting vulnerability in attribute table in QGIS QWC2 < 2025.08.14 allows an authorized attacker to plant arbitrary JavaScript code in the page.

References

  • github.com/advisories/GHSA-gxp8-m5rq-3m38
  • hub.ntc.swiss/ntcf-2025-4286
  • nvd.nist.gov/vuln/detail/CVE-2025-11183

Code Behaviors & Features

Detect and mitigate CVE-2025-11183 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2025.8.14

Fixed versions

  • 2025.8.14

Solution

Upgrade to version 2025.8.14 or above.

Impact 5.2 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/qwc2/CVE-2025-11183.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:11 +0000.