Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. prismjs
  4. ›
  5. CVE-2020-15138

CVE-2020-15138: Cross-site Scripting

August 7, 2020 (updated August 28, 2020)

Prism is vulnerable to Cross-Site Scripting. The easing preview of the previewer plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer.

References

  • nvd.nist.gov/vuln/detail/CVE-2020-15138
  • prismjs.com/plugins/previewers/

Code Behaviors & Features

Detect and mitigate CVE-2020-15138 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.1.0 before 1.21.0

Fixed versions

  • 1.21.0

Solution

Upgrade to version 1.21.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/prismjs/CVE-2020-15138.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:50 +0000.