Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. preact
  4. ›
  5. CVE-2026-22028

CVE-2026-22028: Preact has JSON VNode Injection issue

January 7, 2026 (updated January 8, 2026)

Vulnerability Type: HTML Injection via JSON Type Confusion

Affected Versions: Preact 10.26.5 through 10.28.1

Severity: Low to Medium (see below)

References

  • github.com/advisories/GHSA-36hm-qxxp-pg3m
  • github.com/preactjs/preact
  • github.com/preactjs/preact/security/advisories/GHSA-36hm-qxxp-pg3m
  • nvd.nist.gov/vuln/detail/CVE-2026-22028

Code Behaviors & Features

Detect and mitigate CVE-2026-22028 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 10.26.5 before 10.26.10, all versions starting from 10.27.0 before 10.27.3, all versions starting from 10.28.0 before 10.28.2

Fixed versions

  • 10.26.10
  • 10.27.3
  • 10.28.2

Solution

Upgrade to versions 10.26.10, 10.27.3, 10.28.2 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-843: Access of Resource Using Incompatible Type ('Type Confusion')

Source file

npm/preact/CVE-2026-22028.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.