Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. posthog-js
  4. ›
  5. CVE-2023-32325

CVE-2023-32325: Potential for cross-site scripting in PostHog-js

May 27, 2023 (updated June 3, 2023)

Impact

Potential for cross-site scripting in posthog-js.

Patches

The problem has been patched in posthog-js version 1.57.2.

Workarounds

  • This isn’t an issue for sites that have a Content Security Policy in place.
  • Using the HTML tracking snippet on PostHog Cloud always guarantees the latest version of the library – in that case no action is required to upgrade to the patched version.

References

We will publish details of the vulnerability in 30 days as per our security policy.

References

  • github.com/PostHog/posthog-js/commit/67e07eb8bb271a3a6f4aa251382e4d25abb385a0
  • github.com/PostHog/posthog-js/pull/630
  • github.com/PostHog/posthog-js/security/advisories/GHSA-8775-5hwv-wr6v
  • github.com/advisories/GHSA-8775-5hwv-wr6v

Code Behaviors & Features

Detect and mitigate CVE-2023-32325 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.57.2

Fixed versions

  • 1.57.2

Solution

Upgrade to version 1.57.2 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/posthog-js/CVE-2023-32325.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:39 +0000.