Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. postcss
  4. ›
  5. CVE-2021-23382

CVE-2021-23382: Uncontrolled Resource Consumption

April 26, 2021 (updated August 8, 2023)

The package postcss is vulnerable to Regular Expression Denial of Service (ReDoS) via getAnnotationURL() and loadAnnotation() in lib/previous-map.js.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-23382

Code Behaviors & Features

Detect and mitigate CVE-2021-23382 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 7.0.36, all versions starting from 8.0.0 before 8.2.13

Fixed versions

  • 7.0.36
  • 8.2.13

Solution

Upgrade to versions 7.0.36, 8.2.13 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-1333: Inefficient Regular Expression Complexity

Source file

npm/postcss/CVE-2021-23382.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:01 +0000.