Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. plotly.js
  4. ›
  5. GMS-2016-69

GMS-2016-69: Cross Site Scripting

October 17, 2016

If an attacker can trick an unsuspecting user into viewing a specially crafted plot on a site that uses plotly.js, then the attacker could potentially retrieve authentication tokens and perform actions on behalf of the user.

References

  • help.plot.ly/security-advisories/2016-08-08-plotlyjs-xss-advisory/
  • acloudtree.com/2016-08-09-how-i-hacked-plotly-by-exploiting-a-svg-vulnerability-in-plotlyjs/
  • github.com/plotly/plotly.js/commit/0a1526de6ee872993cabac966ed6fdc67cd052f0
  • github.com/plotly/plotly.js/commit/d58d3bee92cbed88e2da250753d7dcb374d42e1d
  • github.com/plotly/plotly.js/issues/642

Code Behaviors & Features

Detect and mitigate GMS-2016-69 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.10.4, all versions starting from 1.11.0 before 1.16.0

Fixed versions

  • 1.10.4
  • 1.16.0

Solution

Update to 1.16.0 or later.

Source file

npm/plotly.js/GMS-2016-69.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:24 +0000.