Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. parse-server
  4. ›
  5. GMS-2021-186

GMS-2021-186: Incorrect version tags linked to external repository

September 7, 2021 (updated November 2, 2026)

A security incident caused a number of incorrect version tags to be pushed to the Parse Server repository. These version tags linked to a personal fork of a contributor who had write access to the repository. The code to which these tags linked has not been reviewed or approved by Parse Platform. Even though no releases were published with these incorrect versions, it was possible to define a Parse Server dependency that pointed to these version tags, for example if you defined this dependency:

"parse-server": "git@github.com:parse-community/parse-server.git#4.9.3"

We have since deleted the incorrect version tags, but they may still show up in your personal fork on GitHub or locally. We do not know when these tags have been pushed to the Parse Server repository, but we first became aware of this issue on July 21, 2021. We are not aware of any malicious code or concerns related to privacy, security or legality (e.g. proprietary code). However, it has been reported that some functionality does not work as expected and the introduction of security vulnerabilities cannot be ruled out.

You may be also affected if you used the Bitnami image for Parse Server. Bitnami picked up the incorrect version tag 4.9.3 and published a new Bitnami image for Parse Server.

If you are using any of the affected versions, we urgently recommend to upgrade to version 4.10.0.

These are the incorrect tags:

4.0.0-beta1
4.0.0-beta2
4.0.0-beta3
4.0.0-beta4
4.0.0-beta5
4.0.0-beta6
4.0.10
4.0.11
4.0.12
4.0.13
4.0.14
4.0.3
4.0.4
4.0.6
4.0.7
4.0.8
4.0.9
4.6.0
4.6.0-beta
4.7.0
4.8.0
4.8.1
4.8.2
4.8.3
4.8.4
4.8.5
4.9.0
4.9.1
4.9.2
4.9.3

References

  • github.com/advisories/GHSA-593v-wcqx-hq2w
  • github.com/parse-community/parse-server/security/advisories/GHSA-593v-wcqx-hq2w
  • nvd.nist.gov/vuln/detail/CVE-2021-47986
  • nvd.nist.gov/vuln/detail/CVE-2021-47987
  • www.vulncheck.com/advisories/parse-server-arbitrary-code-execution-via-malicious-version-tags
  • www.vulncheck.com/advisories/parse-server-unreviewed-code-execution-via-malicious-version-tags

Code Behaviors & Features

Detect and mitigate GMS-2021-186 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 4.0.0 before 4.5.2, all versions starting from 4.6.0 before 4.10.0

Fixed versions

  • 4.5.2
  • 4.10.0

Solution

Upgrade to versions 4.5.2, 4.10.0 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-484: Omitted Break Statement in Switch
  • CWE-494: Download of Code Without Integrity Check

Source file

npm/parse-server/GMS-2021-186.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:14 +0000.