Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. parse-server
  4. ›
  5. CVE-2025-68115

CVE-2025-68115: Parse Server has a Cross-Site Scripting (XSS) vulnerability via Unescaped Mustache Template Variables

December 16, 2025

A Reflected Cross-Site Scripting (XSS) vulnerability exists in Parse Server’s password reset and email verification HTML pages.

References

  • github.com/advisories/GHSA-jhgf-2h8h-ggxv
  • github.com/parse-community/parse-server
  • github.com/parse-community/parse-server/pull/9985
  • github.com/parse-community/parse-server/pull/9986
  • github.com/parse-community/parse-server/security/advisories/GHSA-jhgf-2h8h-ggxv
  • nvd.nist.gov/vuln/detail/CVE-2025-68115

Code Behaviors & Features

Detect and mitigate CVE-2025-68115 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 8.6.1, all versions starting from 9.0.0 before 9.1.0-alpha.3

Fixed versions

  • 8.6.1
  • 9.1.0-alpha.3

Solution

Upgrade to versions 8.6.1, 9.1.0-alpha.3 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/parse-server/CVE-2025-68115.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:54 +0000.