Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. pac-resolver
  4. ›
  5. CVE-2021-23406

CVE-2021-23406: Remote Code Execution

August 24, 2021 (updated August 30, 2021)

The package pac-resolver is vulnerable to a Remote Code Execution vulnerability. This can occur when used with untrusted input, due to unsafe PAC file handling.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-23406

Code Behaviors & Features

Detect and mitigate CVE-2021-23406 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 5.0.0

Fixed versions

  • 5.0.0

Solution

Upgrade to version 5.0.0 or above.

Impact 9.8 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Source file

npm/pac-resolver/CVE-2021-23406.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:52 +0000.