Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. opencode-ai
  4. ›
  5. CVE-2026-22813

CVE-2026-22813: Malicious website can execute commands on the local system through XSS in the OpenCode web UI

January 13, 2026

A malicious website can abuse the server URL override feature of the OpenCode web UI to achieve cross-site scripting on http://localhost:4096. From there, it is possible to run arbitrary commands on the local system using the /pty/ endpoints provided by the OpenCode API.

References

  • github.com/advisories/GHSA-c83v-7274-4vgp
  • github.com/anomalyco/opencode
  • github.com/anomalyco/opencode/security/advisories/GHSA-c83v-7274-4vgp
  • nvd.nist.gov/vuln/detail/CVE-2026-22813

Code Behaviors & Features

Detect and mitigate CVE-2026-22813 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.1.10

Fixed versions

  • 1.1.10

Solution

Upgrade to version 1.1.10 or above.

Impact 9.6 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/opencode-ai/CVE-2026-22813.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:48 +0000.