Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. openclaw
  4. ›
  5. GHSA-gg9v-mgcp-v6m7

GHSA-gg9v-mgcp-v6m7: OpenClaw: Unbound bootstrap setup codes allow privilege escalation during pairing

April 3, 2026

Bootstrap setup codes were not bound to the intended device role and scopes, allowing first-use privilege escalation during pairing.

References

  • github.com/advisories/GHSA-gg9v-mgcp-v6m7
  • github.com/openclaw/openclaw
  • github.com/openclaw/openclaw/commit/a600c72ed7d0045a27f58bf031d2b36ecb0141c9
  • github.com/openclaw/openclaw/security/advisories/GHSA-gg9v-mgcp-v6m7

Code Behaviors & Features

Detect and mitigate GHSA-gg9v-mgcp-v6m7 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2026.3.22

Fixed versions

  • 2026.3.22

Solution

Upgrade to version 2026.3.22 or above.

Impact 9.3 CRITICAL

CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

npm/openclaw/GHSA-gg9v-mgcp-v6m7.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:21 +0000.