Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. openclaw
  4. ›
  5. GHSA-56pc-6hvp-4gv4

GHSA-56pc-6hvp-4gv4: OpenClaw vulnerable to arbitrary file read via $include directive

March 3, 2026

A successful exploit can expose local secrets and credentials readable by the OpenClaw process user, including API keys and private config material.

References

  • github.com/advisories/GHSA-56pc-6hvp-4gv4
  • github.com/openclaw/openclaw
  • github.com/openclaw/openclaw/commit/d1c00dbb7c64a39e205464dae7f2a068420e91c1
  • github.com/openclaw/openclaw/security/advisories/GHSA-56pc-6hvp-4gv4

Code Behaviors & Features

Detect and mitigate GHSA-56pc-6hvp-4gv4 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2026.2.17

Fixed versions

  • 2026.2.17

Solution

Upgrade to version 2026.2.17 or above.

Impact 6.2 MEDIUM

CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-22: Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')

Source file

npm/openclaw/GHSA-56pc-6hvp-4gv4.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:55 +0000.