Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. openclaw
  4. ›
  5. CVE-2026-41380

CVE-2026-41380: OpenClaw gateway exec allow-always over-trusts positional carrier executables

April 1, 2026 (updated April 28, 2026)

Allow-always persistence could trust wrapper carrier executables instead of the actual invoked target when commands were routed through dispatch wrappers.

References

  • github.com/advisories/GHSA-p4x4-2r7f-wjxg
  • github.com/openclaw/openclaw/commit/9ec44fad390f0bc1c29c3cc418b322560cb0222b
  • github.com/openclaw/openclaw/releases/tag/v2026.3.28
  • github.com/openclaw/openclaw/security/advisories/GHSA-p4x4-2r7f-wjxg
  • nvd.nist.gov/vuln/detail/CVE-2026-41380

Code Behaviors & Features

Detect and mitigate CVE-2026-41380 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2026.3.28

Fixed versions

  • 2026.3.28

Solution

Upgrade to version 2026.3.28 or above.

Impact 7.3 HIGH

CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-863: Incorrect Authorization

Source file

npm/openclaw/CVE-2026-41380.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:22 +0000.