Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. openclaw
  4. ›
  5. CVE-2026-35641

CVE-2026-35641: OpenClaw has an Arbitrary Malicious Code Execution Vulnerability

March 30, 2026 (updated April 10, 2026)

During the installation phase of OpenClaw local plugins/hooks, the Git executable can be hijacked by a project-level .npmrc file, leading to arbitrary code execution during installation.

References

  • github.com/advisories/GHSA-m3mh-3mpg-37hw
  • github.com/openclaw/openclaw
  • github.com/openclaw/openclaw/security/advisories/GHSA-m3mh-3mpg-37hw
  • nvd.nist.gov/vuln/detail/CVE-2026-35641

Code Behaviors & Features

Detect and mitigate CVE-2026-35641 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 2026.3.24

Fixed versions

  • 2026.3.24

Solution

Upgrade to version 2026.3.24 or above.

Impact 7.8 HIGH

CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-426: Untrusted Search Path

Source file

npm/openclaw/CVE-2026-35641.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:23 +0000.