Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nodebb
  4. ›
  5. CVE-2024-57041

CVE-2024-57041: NodeBB Cross-site scripting (XSS) vulnerability

January 24, 2025 (updated February 7, 2025)

A persistent cross-site scripting (XSS) vulnerability in NodeBB v3.11.0 allows remote attackers to store arbitrary code in the ‘about me’ section of their profile.

References

  • github.com/NodeBB/NodeBB
  • github.com/NodeBB/NodeBB/commit/4e69bff72fd04779064d37e46a43080e6c328adf
  • github.com/advisories/GHSA-vqr3-vrrg-f3jh
  • nvd.nist.gov/vuln/detail/CVE-2024-57041
  • www.tonysec.com/posts/cve-2024-57041

Code Behaviors & Features

Detect and mitigate CVE-2024-57041 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 3.11.1

Fixed versions

  • 3.11.1

Solution

Upgrade to version 3.11.1 or above.

Impact 4.6 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/nodebb/CVE-2024-57041.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:48 +0000.