Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. node-weakauras-parser
  4. ›
  5. GMS-2020-407

GMS-2020-407: Buffer Overflow in node-weakauras-parser

September 3, 2020 (updated October 4, 2021)

Affected versions of node-weakauras-parser are vulnerable to a Buffer Overflow. The encode_weakaura function fails to properly validate the input size. A buffer of bytes causes an overflow on systems. Upgrade to or later.

References

  • github.com/Zireael-N/node-weakauras-parser/commit/bc146da09db689e554d28e948f1cf1c138f09f69
  • github.com/advisories/GHSA-86mr-6m89-vgj3
  • www.npmjs.com/advisories/1504

Code Behaviors & Features

Detect and mitigate GMS-2020-407 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 1.0.4 before 1.0.5, all versions starting from 2.0.0 before 2.0.2, all versions starting from 3.0.0 before 3.0.1

Fixed versions

  • 1.0.5
  • 2.0.2
  • 3.0.1

Solution

Upgrade to versions 1.0.5, 2.0.2, 3.0.1 or above.

Source file

npm/node-weakauras-parser/GMS-2020-407.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:06 +0000.