Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. node-red
  4. ›
  5. CVE-2019-15607

CVE-2019-15607: Cross-site Scripting

January 28, 2020 (updated January 29, 2020)

A stored XSS vulnerability is present within the node-red npm package, which is a visual tool for wiring the Internet of Things. This issue will allow the attacker to steal session cookies, deface web applications, etc.

References

  • hackerone.com/reports/681986
  • nvd.nist.gov/vuln/detail/CVE-2019-15607

Code Behaviors & Features

Detect and mitigate CVE-2019-15607 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions up to 0.20.7

Fixed versions

  • 0.20.8

Solution

Upgrade to version 0.20.8 or above.

Impact 5.4 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')

Source file

npm/node-red/CVE-2019-15607.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:42 +0000.