Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. node-jose
  4. ›
  5. CVE-2017-16007

CVE-2017-16007: Inadequate Encryption Strength

June 4, 2018 (updated October 9, 2019)

node-jose is vulnerable to an invalid curve attack. This allows an attacker to recover the private secret key when JWE with Key Agreement with Elliptic Curve Diffie-Hellman Ephemeral Static (ECDH-ES) is used.

References

  • nvd.nist.gov/vuln/detail/CVE-2017-16007

Code Behaviors & Features

Detect and mitigate CVE-2017-16007 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.9.3

Fixed versions

  • 0.9.3

Solution

Upgrade to version 0.9.3 or above.

Impact 5.9 MEDIUM

CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Source file

npm/node-jose/CVE-2017-16007.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:47 +0000.