Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. node-forge
  4. ›
  5. CVE-2025-66030

CVE-2025-66030: node-forge is vulnerable to ASN.1 OID Integer Truncation

November 26, 2025 (updated December 1, 2025)

MITRE-Formatted CVE Description An Integer Overflow (CWE-190) vulnerability in node-forge versions 1.3.1 and below enables remote, unauthenticated attackers to craft ASN.1 structures containing OIDs with oversized arcs. These arcs may be decoded as smaller, trusted OIDs due to 32-bit bitwise truncation, enabling the bypass of downstream OID-based security decisions.

References

  • github.com/advisories/GHSA-65ch-62r8-g69g
  • github.com/digitalbazaar/forge
  • github.com/digitalbazaar/forge/commit/3e0c35ace169cfca529a3e547a7848dc7bf57fdb
  • github.com/digitalbazaar/forge/security/advisories/GHSA-65ch-62r8-g69g
  • nvd.nist.gov/vuln/detail/CVE-2025-66030

Code Behaviors & Features

Detect and mitigate CVE-2025-66030 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 1.3.2

Fixed versions

  • 1.3.2

Solution

Upgrade to version 1.3.2 or above.

Impact 5.3 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-190: Integer Overflow or Wraparound

Source file

npm/node-forge/CVE-2025-66030.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:42 +0000.