Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nocodb
  4. ›
  5. CVE-2023-5104

CVE-2023-5104: Improper Input Validation

September 21, 2023

Improper Input Validation in GitHub repository nocodb/nocodb prior to 0.96.0.

References

  • github.com/advisories/GHSA-xrpm-hccg-28x7
  • github.com/nocodb/nocodb/commit/db0385cb8aab2a34e233454607f59152ac62b3e2
  • huntr.dev/bounties/1b5c6d9f-941e-4dd7-a964-42b53d6826b0
  • nvd.nist.gov/vuln/detail/CVE-2023-5104

Code Behaviors & Features

Detect and mitigate CVE-2023-5104 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.96.0

Fixed versions

  • 0.96.0

Solution

Upgrade to version 0.96.0 or above.

Impact 6.5 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H

Learn more about CVSS

Weakness

  • CWE-20: Improper Input Validation

Source file

npm/nocodb/CVE-2023-5104.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:08 +0000.