Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nocodb
  4. ›
  5. CVE-2022-2064

CVE-2022-2064: Insufficient Session Expiration

June 14, 2022 (updated June 24, 2022)

Insufficient Session Expiration in GitHub repository nocodb/nocodb prior to 0.91.7+.

References

  • github.com/advisories/GHSA-6293-2vg2-pmp5
  • github.com/nocodb/nocodb/commit/c9b5111b25aea2781e19395a8e9107ddbd235a2b
  • github.com/nocodb/nocodb/pull/2262
  • github.com/nocodb/nocodb/pull/2338
  • github.com/nocodb/nocodb/releases/tag/0.91.9
  • huntr.dev/bounties/39523d51-fc5c-48b8-a082-171da79761bb
  • nvd.nist.gov/vuln/detail/CVE-2022-2064

Code Behaviors & Features

Detect and mitigate CVE-2022-2064 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.91.9

Fixed versions

  • 0.91.9

Solution

Upgrade to version 0.91.9 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-613: Insufficient Session Expiration

Source file

npm/nocodb/CVE-2022-2064.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:38 +0000.