Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nocodb
  4. ›
  5. CVE-2022-2063

CVE-2022-2063: Improper Privilege Management

June 14, 2022 (updated June 24, 2022)

Improper Privilege Management in GitHub repository nocodb/nocodb prior to 0.91.7+.

References

  • github.com/advisories/GHSA-fq4h-m3c8-8m2v
  • github.com/nocodb/nocodb/commit/269a19c2ad89a0e8a7596498e3806ff2ec1040c2
  • github.com/nocodb/nocodb/pull/2262
  • github.com/nocodb/nocodb/pull/2337
  • huntr.dev/bounties/156f405b-21d6-4384-9bff-17ebfe484e20
  • nvd.nist.gov/vuln/detail/CVE-2022-2063

Code Behaviors & Features

Detect and mitigate CVE-2022-2063 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.91.8

Fixed versions

  • 0.91.8

Solution

Upgrade to version 0.91.8 or above.

Impact 8.8 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-269: Improper Privilege Management

Source file

npm/nocodb/CVE-2022-2063.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:18 +0000.