Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nocodb
  4. ›
  5. CVE-2022-2062

CVE-2022-2062: Generation of Error Message Containing Sensitive Information

June 14, 2022 (updated June 30, 2023)

Generation of Error Message Containing Sensitive Information in GitHub repository nocodb/nocodb prior to 0.91.7+.

References

  • github.com/advisories/GHSA-mx8q-jqwm-85mv
  • github.com/nocodb/nocodb/commit/a18f5dd53811b9ec1c1bb2fdbfb328c0c87d7fb4
  • huntr.dev/bounties/35593b4c-f127-4699-8ad3-f0b2203a8ef6
  • nvd.nist.gov/vuln/detail/CVE-2022-2062

Code Behaviors & Features

Detect and mitigate CVE-2022-2062 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.91.7

Fixed versions

  • 0.91.7

Solution

Upgrade to version 0.91.7 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

Learn more about CVSS

Weakness

  • CWE-209: Generation of Error Message Containing Sensitive Information

Source file

npm/nocodb/CVE-2022-2062.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:56 +0000.