Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. ngx-extended-pdf-viewer
  4. ›
  5. GHSA-w9hm-4m3m-fxmm

GHSA-w9hm-4m3m-fxmm: ngx-extended-pdf-viewer bundles a version of pdf.js vulnerable to CVE-2026-16633

August 6, 2026

ngx-extended-pdf-viewer embeds a fork of Mozilla’s pdf.js rather than depending on pdfjs-dist, so this vulnerability is not visible to dependency scanners through package.json.

References

  • github.com/advisories/GHSA-w9hm-4m3m-fxmm
  • github.com/stephanrauh/ngx-extended-pdf-viewer/security/advisories/GHSA-w9hm-4m3m-fxmm

Code Behaviors & Features

Detect and mitigate GHSA-w9hm-4m3m-fxmm with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 27.0.0-rc.0 before 29.0.0-rc.3

Fixed versions

  • 29.0.0-rc.3

Solution

Upgrade to version 29.0.0-rc.3 or above.

Impact 8.1 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N

Learn more about CVSS

Weakness

  • CWE-1103: Use of Platform-Dependent Third Party Components

Source file

npm/ngx-extended-pdf-viewer/GHSA-w9hm-4m3m-fxmm.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:32 +0000.