Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. next
  4. ›
  5. GHSA-2464-fhr4-w9xw

GHSA-2464-fhr4-w9xw: Next.js: Unauthenticated Remote Code Execution in Image Optimization API when SVG files are used

October 22, 2026

A memory-related vulnerability has been discovered in an upstream library used for Image Optimization can lead to possible remote code execution (RCE) when Next.js runs on glibc-based Linux.

References

  • github.com/advisories/GHSA-2464-fhr4-w9xw
  • github.com/vercel/next.js/commit/5e3b687b5edb868b064bdc058d768a7021e7f6ad
  • github.com/vercel/next.js/commit/9571ec899f063df6533351bec390ccb2cc0af6a3
  • github.com/vercel/next.js/releases/tag/v15.5.28
  • github.com/vercel/next.js/releases/tag/v16.4.1
  • github.com/vercel/next.js/security/advisories/GHSA-2464-fhr4-w9xw
  • nvd.nist.gov/vuln/detail/CVE-2026-96889

Code Behaviors & Features

Detect and mitigate GHSA-2464-fhr4-w9xw with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 10.0.0 before 15.5.28, all versions starting from 16.0.0 before 16.4.1

Fixed versions

  • 15.5.28
  • 16.4.1

Solution

Upgrade to versions 15.5.28, 16.4.1 or above.

Impact 10 CRITICAL

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-1395: Dependency on Vulnerable Third-Party Component

Source file

npm/next/GHSA-2464-fhr4-w9xw.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:16:12 +0000.