Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. next
  4. ›
  5. CVE-2026-94544

CVE-2026-94544: Next.js: Pending `use cache` fill can leak Draft Mode content into regular responses and persisted pages

October 7, 2026

Pending use cache fills are shared across requests for the same key without distinguishing Draft Mode requests from regular requests. When two such requests overlap, the second request receives the first request’s fill:

  • A regular request that overlaps an editor’s Draft Mode request receives unpublished content, without any authentication.
  • A Draft Mode request that overlaps a regular request receives published content instead of the draft.

If the overlapping regular request prerenders a page — for example an on-demand prerender of a route that was not prerendered at build time — the unpublished content can be persisted into the generated page and served to all later visitors of that route until the page is revalidated. Since cached functions can be shared across routes, the poisoned page does not need to be the page the editor is previewing.

Sites are affected if they enable Cache Components (or experimental.useCache) and serve Draft Mode previews whose cached functions return draft-dependent content.

References

  • github.com/advisories/GHSA-3w37-wq28-93x7
  • github.com/vercel/next.js/commit/bd9214f9a32854a011bf5fe58e481dffe1bbf598
  • github.com/vercel/next.js/releases/tag/v16.3.8
  • github.com/vercel/next.js/security/advisories/GHSA-3w37-wq28-93x7
  • nvd.nist.gov/vuln/detail/CVE-2026-94544

Code Behaviors & Features

Detect and mitigate CVE-2026-94544 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 16.3.0 before 16.3.8

Fixed versions

  • 16.3.8

Solution

Upgrade to version 16.3.8 or above.

Impact 4.2 MEDIUM

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N

Learn more about CVSS

Weakness

  • CWE-524: Use of Cache Containing Sensitive Information

Source file

npm/next/CVE-2026-94544.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:57 +0000.