Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. next
  4. ›
  5. CVE-2021-43803

CVE-2021-43803: Improper Input Validation

December 10, 2021 (updated January 30, 2024)

Next handling invalid or malformed URLs could lead to a server crash. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js.

References

  • github.com/vercel/next.js/commit/6d98b4fb4315dec1badecf0e9bdc212a4272b264
  • github.com/vercel/next.js/pull/32080
  • github.com/vercel/next.js/releases/tag/v11.1.3
  • github.com/vercel/next.js/releases/v12.0.5
  • github.com/vercel/next.js/security/advisories/GHSA-25mp-g6fv-mqxx
  • nvd.nist.gov/vuln/detail/CVE-2021-43803

Code Behaviors & Features

Detect and mitigate CVE-2021-43803 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 11.1.0 before 11.1.3, all versions starting from 12.0.0 before 12.0.5

Fixed versions

  • 11.1.3
  • 12.0.5

Solution

Upgrade to versions 11.1.3, 12.0.5 or above.

Impact 7.5 HIGH

CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Learn more about CVSS

Source file

npm/next/CVE-2021-43803.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:23 +0000.