Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. next
  4. ›
  5. CVE-2021-39178

CVE-2021-39178: Cross-site Scripting

August 31, 2021 (updated September 8, 2021)

Next is vulnerable to XSS.

References

  • nvd.nist.gov/vuln/detail/CVE-2021-39178

Code Behaviors & Features

Detect and mitigate CVE-2021-39178 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions starting from 10.0.0 before 11.1.1

Fixed versions

  • 11.1.1

Solution

Upgrade to version 11.1.1 or above.

Impact 6.1 MEDIUM

CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Learn more about CVSS

Source file

npm/next/CVE-2021-39178.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:17:05 +0000.