Advisory Database
  • Advisories
  • Dependency Scanning
  1. npm
  2. ›
  3. nemo-appium
  4. ›
  5. CVE-2022-21129

CVE-2022-21129: nemo-appium vulnerable to OS Command Injection

January 31, 2023 (updated March 27, 2025)

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the ‘module.exports.setup’ function.

Note: In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.

References

  • github.com/advisories/GHSA-c6rx-gxqv-vr5j
  • github.com/paypal/nemo-appium
  • github.com/paypal/nemo-appium/blob/master/index.js%23L27
  • github.com/paypal/nemo-appium/commit/aa271d36dd5c81baae3c43aa2616c84f0ee4195f
  • nvd.nist.gov/vuln/detail/CVE-2022-21129
  • security.snyk.io/vuln/SNYK-JS-NEMOAPPIUM-3183747

Code Behaviors & Features

Detect and mitigate CVE-2022-21129 with GitLab Dependency Scanning

Secure your software supply chain by verifying that all open source dependencies used in your projects contain no disclosed vulnerabilities. Dependency Scanning using SBOM also detects vulnerabilities from proprietary advisories that this site does not include. Learn more about Dependency Scanning using SBOM →

Affected versions

All versions before 0.0.9

Fixed versions

  • 0.0.9

Solution

Upgrade to version 0.0.9 or above.

Impact 7.4 HIGH

CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Learn more about CVSS

Weakness

  • CWE-77: Improper Neutralization of Special Elements used in a Command ('Command Injection')
  • CWE-78: Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection')

Source file

npm/nemo-appium/CVE-2022-21129.yml

Spotted a mistake? Edit the file on GitLab.

  • Site Repo
  • About GitLab
  • Terms
  • Privacy Statement
  • Contact

Page generated Sun, 08 Nov 2026 00:15:20 +0000.